Kerentanan Ditemukan di Lima Plugin WordPress WooCommerce

Kerentanan Ditemukan di Lima Plugin WordPress WooCommerce

Database Kerentanan Nasional (NVD) pemerintah AS menerbitkan peringatan kerentanan di lima plugin WordPress WooCommerce yang memengaruhi lebih dari 135.000 instalasi.

Banyak kerentanan berkisar dalam tingkat keparahan hingga Kritis dan diberi peringkat 9,8 pada skala 1-10.

Setiap kerentanan diberi nomor identitas CVE (Kerentanan Umum dan Eksposur) yang diberikan kepada kerentanan yang ditemukan.

1. Ekspor Pesanan Lanjutan Untuk WooCommerce

Plugin Ekspor Pesanan Lanjutan untuk WooCommerce, yang dipasang di lebih dari 100.000 situs web, rentan terhadap serangan Pemalsuan Permintaan Lintas Situs (CSRF).

Kerentanan Pemalsuan Permintaan Lintas Situs (CSRF) muncul dari cacat pada plugin situs web yang memungkinkan penyerang mengelabui pengguna situs web agar melakukan tindakan yang tidak diinginkan.

Peramban situs web biasanya berisi cookie yang memberi tahu situs web bahwa pengguna terdaftar dan masuk. Penyerang dapat mengambil tingkat hak istimewa admin. Ini memberi penyerang akses penuh ke situs web, memaparkan informasi pelanggan yang sensitif, dan sebagainya.

Kerentanan khusus ini dapat menyebabkan unduhan file ekspor. Deskripsi kerentanan tidak menjelaskan file apa yang dapat diunduh oleh penyerang.

Mengingat bahwa tujuan plugin adalah untuk mengekspor data pesanan WooCommerce, mungkin masuk akal untuk mengasumsikan bahwa data pesanan adalah jenis file yang dapat diakses oleh penyerang.

Deskripsi kerentanan resmi:

“Kerentanan Pemalsuan Permintaan Lintas Situs (CSRF) di Ekspor Pesanan Lanjutan Untuk plugin WooCommerce <= 3.3.2 di WordPress yang mengarah ke unduhan file ekspor.”

Kerentanan memengaruhi semua versi plugin Ekspor Pesanan Lanjutan untuk WooCommerce yang kurang dari atau sama dengan versi 3.3.2.

Resmi changelog untuk plugin mencatat bahwa kerentanan telah ditambal di versi 3.3.3.

Baca lebih lanjut di Database Kerentanan Nasional (NVD): CVE-2022-40128

2. Harga Dinamis Lanjutan untuk WooCommerce

Plugin kedua yang terpengaruh adalah plugin Advanced Dynamic Pricing untuk WooCommerce yang dipasang di lebih dari 20.000 situs web.

Plugin ini diketahui memiliki dua kerentanan Pemalsuan Permintaan Lintas Situs (CSRF) yang memengaruhi semua versi plugin di bawah 4.1.6.

Tujuan dari plugin adalah untuk memudahkan pedagang membuat diskon dan aturan harga.

Kerentanan pertama (CVE-2022-43488) dapat menyebabkan “migrasi jenis aturan.”

Itu agak kabur. Mungkin asumsi dapat dibuat bahwa kerentanan mungkin ada hubungannya dengan kemampuan untuk mengubah aturan penetapan harga.

Deskripsi resmi yang diberikan di NVD:

“Kerentanan Pemalsuan Permintaan Lintas Situs (CSRF) dalam Harga Dinamis Lanjutan untuk plugin WooCommerce <= 4.1.5 di WordPress yang mengarah ke migrasi jenis aturan.”

Baca selengkapnya di NVD: CVE-2022-43488

NVD menetapkan kerentanan CSRF kedua di plugin Advanced Dynamic Pricing for WooCommerce sebuah nomor CVE, CVE-2022-43491.

Deskripsi resmi NVD tentang kerentanan adalah:

“Kerentanan Pemalsuan Permintaan Lintas Situs (CSRF) dalam Harga Dinamis Lanjutan untuk plugin WooCommerce <= 4.1.5 di WordPress yang mengarah ke impor pengaturan plugin.”

Resmi log perubahan plugin catatan:

“Log perubahan – 4.1.6 – 2022-10-26

Memperbaiki beberapa CSRF dan kerentanan kontrol akses yang rusak”

Baca pengumuman resmi NVD: CVE-2022-43491

3. Kupon Lanjutan untuk plugin Kupon WooCommerce

Plugin ketiga yang terpengaruh, Kupon Lanjutan untuk Kupon WooCommerce, memiliki lebih dari 10.000 pemasangan.

Masalah yang ditemukan di plugin ini juga merupakan kerentanan CSRF dan memengaruhi semua versi di bawah 4.5.01.

Itu log perubahan plugin memanggil tambalan sebagai perbaikan bug?

“4.5.0.1

Perbaikan Bug: Pemberitahuan memulai mengabaikan permintaan AJAX tidak memiliki nilai nonce.

Deskripsi NVD resmi adalah:

“Kerentanan Pemalsuan Permintaan Lintas Situs (CSRF) di Kupon Lanjutan untuk plugin Kupon WooCommerce <= 4,5 di WordPress yang mengarah ke pemberitahuan pemberhentian.”

Baca selengkapnya di NVD: CVE-2022-43481

4. Dropshipping WooCommerce oleh OPMC – Penting

Perangkat lunak keempat yang terpengaruh adalah plugin WooCommerce Dropshipping oleh OPMC yang memiliki lebih dari 3.000 instalasi.

Versi plugin ini kurang dari versi 4.4 mengandung kerentanan injeksi SQL yang tidak diautentikasi dengan peringkat 9,8 (pada skala 1-10) dan diberi label sebagai Kritis.

Secara umum, kerentanan injeksi SQL memungkinkan penyerang untuk memanipulasi database WordPress dan mengambil izin tingkat admin, membuat perubahan pada database, menghapus database, atau bahkan mengunduh data sensitif.

NVD menjelaskan kerentanan plugin khusus ini:

“Plugin WordPress Dropshipping WooCommerce sebelum 4.4 tidak membersihkan dan menghindari parameter dengan benar sebelum menggunakannya dalam pernyataan SQL melalui titik akhir REST yang tersedia untuk pengguna yang tidak diautentikasi, yang mengarah ke injeksi SQL.”

Baca selengkapnya di NVD: CVE-2022-3481

Baca resmi log perubahan plugin.

5. Penetapan Harga Berdasarkan Peran untuk WooCommerce

Plugin Penetapan Harga Berbasis Peran untuk WooCommerce memiliki dua kerentanan Pemalsuan Permintaan Lintas Situs (CSRF). Ada 2.000 instalasi plugin ini.

Seperti yang disebutkan tentang plugin lain, kerentanan CSRF umumnya melibatkan penyerang yang menipu admin atau pengguna lain untuk mengklik tautan atau melakukan tindakan lain. Itu dapat mengakibatkan penyerang mendapatkan tingkat izin situs web pengguna.

Kerentanan ini diberi peringkat 8.8 Tinggi.

Deskripsi NVD dari kerentanan pertama memperingatkan:

“Harga Berbasis Peran untuk plugin WordPress WooCommerce sebelum 1.6.2 tidak memiliki otorisasi dan pemeriksaan CSRF yang tepat, dan tidak memvalidasi file yang akan diunggah, memungkinkan pengguna yang diautentikasi seperti pelanggan untuk mengunggah file sewenang-wenang, seperti PHP”

Berikut ini adalah deskripsi NVD resmi dari kerentanan kedua:

“Harga Berbasis Peran untuk plugin WooCommerce WordPress sebelum 1.6.3 tidak memiliki otorisasi dan pemeriksaan CSRF yang tepat, serta tidak memvalidasi jalur yang diberikan melalui input pengguna, memungkinkan setiap pengguna yang diautentikasi seperti pelanggan untuk melakukan serangan deserialisasi PHAR ketika mereka dapat mengunggah file, dan rantai gadget yang sesuai hadir di blog”

Harga Berbasis Peran resmi untuk plugin WordPress WooCommerce log perubahan menyarankan agar plugin sepenuhnya ditambal di versi 1.6.2:

“Changelog 2022-10-01 – versi 1.6.2

* Memperbaiki Kerentanan Unggah File Sewenang-wenang.

* Memperbaiki masalah cek nonce ajax.”

Baca dokumentasi NVD resmi:

CVE-2022-3537

CVE-2022-3536

Kursus Tindakan

Ini dianggap sebagai praktik yang baik untuk memperbarui semua plugin yang rentan. Ini juga merupakan praktik terbaik untuk mencadangkan situs sebelum membuat pembaruan plugin apa pun dan (jika mungkin) untuk mengatur situs dan menguji plugin sebelum memperbarui.


Gambar unggulan oleh Shutterstock/Master1305

Share

Leave a Reply

Your email address will not be published. Required fields are marked *